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Stay	organized	with	collections	Save	and	categorize	content	based	on	your	preferences.	In	this	codelab,	you'll	learn	how	to	build	and	run	your	first	Android	app	in	the	Java	programming	language.	(If	you're	looking	for	the	Kotlin	version	of	this	codelab,	you	can	go	here.)	What	you	must	know	already	This	codelab	is	written	for	programmers	and
assumes	that	you	know	either	the	Java	or	Kotlin	programming	language.	If	you	are	an	experienced	programmer	and	adept	at	reading	code,	you	will	likely	be	able	to	follow	this	codelab,	even	if	you	don't	have	much	experience	with	Java.	What	you'll	learn	How	to	use	Android	Studio	to	build	your	app.	How	to	run	your	app	on	a	device	or	in	the	emulator.
How	to	add	interactive	buttons.	How	to	display	a	second	screen	when	a	button	is	pressed.	Use	Android	Studio	and	Java	to	write	Android	apps	You	write	Android	apps	in	the	Java	programming	language	using	an	IDE	called	Android	Studio.	Based	on	JetBrains'	IntelliJ	IDEA	software,	Android	Studio	is	an	IDE	designed	specifically	for	Android
development.	To	work	through	this	codelab,	you	will	need	a	computer	that	can	run	Android	Studio	3.6	or	higher	(or	already	has	Android	Studio	3.6	or	higher	installed).	You	can	download	Android	Studio	3.6	from	the	Android	Studio	page.	Android	Studio	provides	a	complete	IDE,	including	an	advanced	code	editor	and	app	templates.	It	also	contains
tools	for	development,	debugging,	testing,	and	performance	that	make	it	faster	and	easier	to	develop	apps.	You	can	use	Android	Studio	to	test	your	apps	with	a	large	range	of	preconfigured	emulators,	or	on	your	own	mobile	device.	You	can	also	build	production	apps	and	publish	apps	on	the	Google	Play	store.	Note:	Android	Studio	is	continually	being
improved.	For	the	latest	information	on	system	requirements	and	installation	instructions,	see	the	Android	Studio	download	page.	Android	Studio	is	available	for	computers	running	Windows	or	Linux,	and	for	Macs	running	macOS.	The	OpenJDK	(Java	Development	Kit)	is	bundled	with	Android	Studio.	The	installation	is	similar	for	all	platforms.	Any
differences	are	noted	below.	Navigate	to	the	Android	Studio	download	page	and	follow	the	instructions	to	download	and	install	Android	Studio.	Accept	the	default	configurations	for	all	steps,	and	ensure	that	all	components	are	selected	for	installation.	After	the	install	is	complete,	the	setup	wizard	downloads	and	installs	additional	components,
including	the	Android	SDK.	Be	patient,	because	this	process	might	take	some	time,	depending	on	your	internet	speed.	When	the	installation	completes,	Android	Studio	starts,	and	you	are	ready	to	create	your	first	project.	Troubleshooting:	If	you	run	into	problems	with	your	installation,	see	the	Android	Studio	release	notes	or	Troubleshoot	Android
Studio.	In	this	step,	you	will	create	a	new	Android	project	for	your	first	app.	This	simple	app	displays	the	string	"Hello	World"	on	the	screen	of	an	Android	virtual	or	physical	device.	Here's	what	the	finished	app	will	look	like:	What	you'll	learn	How	to	create	a	project	in	Android	Studio.	How	to	create	an	emulated	Android	device.	How	to	run	your	app	on
the	emulator.	How	to	run	your	app	on	your	own	physical	device,	if	you	have	one.	Step	1:	Create	a	new	project	Open	Android	Studio.	In	the	Welcome	to	Android	Studio	dialog,	click	Start	a	new	Android	Studio	project.	Select	Basic	Activity	(not	the	default).	Click	Next.	Give	your	application	a	name	such	as	My	First	App.	Make	sure	the	Language	is	set	to
Java.	Leave	the	defaults	for	the	other	fields.	Click	Finish.	After	these	steps,	Android	Studio:	Creates	a	folder	for	your	Android	Studio	project	called	MyFirstApp.	This	is	usually	in	a	folder	called	AndroidStudioProjects	below	your	home	directory.	Builds	your	project	(this	may	take	a	few	moments).	Android	Studio	uses	Gradle	as	its	build	system.	You	can
follow	the	build	progress	at	the	bottom	of	the	Android	Studio	window.	Opens	the	code	editor	showing	your	project.	Step	2:	Get	your	screen	set	up	When	your	project	first	opens	in	Android	Studio,	there	may	be	a	lot	of	windows	and	panes	open.	To	make	it	easier	to	get	to	know	Android	Studio,	here	are	some	suggestions	on	how	to	customize	the	layout.
If	there's	a	Gradle	window	open	on	the	right	side,	click	on	the	minimize	button	(—)	in	the	upper	right	corner	to	hide	it.	Depending	on	the	size	of	your	screen,	consider	resizing	the	pane	on	the	left	showing	the	project	folders	to	take	up	less	space.	At	this	point,	your	screen	should	look	a	bit	less	cluttered,	similar	to	the	screenshot	shown	below.	Step	3:
Explore	the	project	structure	and	layout	The	upper	left	of	the	Android	Studio	window	should	look	similar	to	the	following	diagram:	Based	on	you	selecting	the	Basic	Activity	template	for	your	project,	Android	Studio	has	set	up	a	number	of	files	for	you.	You	can	look	at	the	hierarchy	of	the	files	for	your	app	in	multiple	ways,	one	is	in	Project	view.	Project
view	shows	your	files	and	folders	structured	in	a	way	that	is	convenient	for	working	with	an	Android	project.	(This	does	not	always	match	the	file	hierarchy!	To	see	the	file	hierarchy,	choose	the	Project	files	view	by	clicking	(3).)	Double-click	the	app	(1)	folder	to	expand	the	hierarchy	of	app	files.	(See	(1)	in	the	screenshot.)	If	you	click	Project	(2),	you
can	hide	or	show	the	Project	view.	You	might	need	to	select	View	>	Tool	Windows	to	see	this	option.	The	current	Project	view	selection	(3)	is	Project	>	Android.	In	the	Project	>	Android	view	you	see	three	or	four	top-level	folders	below	your	app	folder:	manifests,	java,	java	(generated)	and	res.	You	may	not	see	java	(generated)	right	away.	Expand	the
manifests	folder.	This	folder	contains	AndroidManifest.xml.	This	file	describes	all	the	components	of	your	Android	app	and	is	read	by	the	Android	runtime	system	when	your	app	is	executed.	2.	Expand	the	java	folder.	All	your	Java	language	files	are	organized	here.	The	java	folder	contains	three	subfolders:	com.example.myfirstapp:	This	folder	contains
the	Java	source	code	files	for	your	app.	com.example.myfirstapp	(androidTest):	This	folder	is	where	you	would	put	your	instrumented	tests,	which	are	tests	that	run	on	an	Android	device.	It	starts	out	with	a	skeleton	test	file.	com.example.myfirstapp	(test):	This	folder	is	where	you	would	put	your	unit	tests.	Unit	tests	don't	need	an	Android	device	to
run.	It	starts	out	with	a	skeleton	unit	test	file.	3.	Expand	the	res	folder.	This	folder	contains	all	the	resources	for	your	app,	including	images,	layout	files,	strings,	icons,	and	styling.	It	includes	these	subfolders:	drawable:	All	your	app's	images	will	be	stored	in	this	folder.	layout:	This	folder	contains	the	UI	layout	files	for	your	activities.	Currently,	your
app	has	one	activity	that	has	a	layout	file	called	activity_main.xml.	It	also	contains	content_main.xml,	fragment_first.xml,	and	fragment_second.xml.	menu:	This	folder	contains	XML	files	describing	any	menus	in	your	app.	mipmap:	This	folder	contains	the	launcher	icons	for	your	app.	navigation:	This	folder	contains	the	navigation	graph,	which	tells
Android	Studio	how	to	navigate	between	different	parts	of	your	application.	values:	This	folder	contains	resources,	such	as	strings	and	colors,	used	in	your	app.	Step	4:	Create	a	virtual	device	(emulator)	In	this	task,	you	will	use	the	Android	Virtual	Device	(AVD)	manager	to	create	a	virtual	device	(or	emulator)	that	simulates	the	configuration	for	a
particular	type	of	Android	device.	The	first	step	is	to	create	a	configuration	that	describes	the	virtual	device.	In	Android	Studio,	select	Tools	>	AVD	Manager,	or	click	the	AVD	Manager	icon	in	the	toolbar.	Click	+Create	Virtual	Device.	(If	you	have	created	a	virtual	device	before,	the	window	shows	all	of	your	existing	devices	and	the	+Create	Virtual
Device	button	is	at	the	bottom.)	The	Select	Hardware	window	shows	a	list	of	pre-configured	hardware	device	definitions.	Choose	a	device	definition,	such	as	Pixel	2,	and	click	Next.	(For	this	codelab,	it	really	doesn't	matter	which	device	definition	you	pick).	In	the	System	Image	dialog,	from	the	Recommended	tab,	choose	the	latest	release.	(This	does
matter.)	If	a	Download	link	is	visible	next	to	a	latest	release,	it	is	not	installed	yet,	and	you	need	to	download	it	first.	If	necessary,	click	the	link	to	start	the	download,	and	click	Next	when	it's	done.	This	may	take	a	while	depending	on	your	connection	speed.	Note:	System	images	can	take	up	a	large	amount	of	disk	space,	so	just	download	what	you
need.	In	the	next	dialog	box,	accept	the	defaults,	and	click	Finish.	The	AVD	Manager	now	shows	the	virtual	device	you	added.	If	the	Your	Virtual	Devices	AVD	Manager	window	is	still	open,	go	ahead	and	close	it.	Step	5:	Run	your	app	on	your	new	emulator	In	Android	Studio,	select	Run	>	Run	‘app'	or	click	the	Run	icon	in	the	toolbar.	The	icon	will
change	when	your	app	is	already	running.	If	you	get	a	dialog	box	stating	"Instant	Run	requires	that	the	platform	corresponding	to	your	target	device	(Android	N...)	is	installed"	go	ahead	and	click	Install	and	continue.	In	Run	>	Select	Device,	under	Available	devices,	select	the	virtual	device	that	you	just	configured.	This	menu	also	appears	in	the
toolbar.	The	emulator	starts	and	boots	just	like	a	physical	device.	Depending	on	the	speed	of	your	computer,	this	may	take	a	while.	You	can	look	in	the	small	horizontal	status	bar	at	the	very	bottom	of	Android	Studio	for	messages	to	see	the	progress.	Messages	that	might	appear	briefly	in	the	status	bar	Gradle	build	running	Waiting	for	target	device	to
come	on	line	Installing	APK	Launching	activity	Once	your	app	builds	and	the	emulator	is	ready,	Android	Studio	uploads	the	app	to	the	emulator	and	runs	it.	You	should	see	your	app	as	shown	in	the	following	screenshot.	Note:	It	is	a	good	practice	to	start	the	emulator	at	the	beginning	of	your	session.	Don't	close	the	emulator	until	you	are	done	testing
your	app,	so	that	you	don't	have	to	wait	for	the	emulator	to	boot	again.	Also,	don't	have	more	than	one	emulator	running	at	once,	to	reduce	memory	usage.	Step	6:	Run	your	app	on	a	device	(if	you	have	one)	What	you	need:	An	Android	device	such	as	a	phone	or	tablet.	A	data	cable	to	connect	your	Android	device	to	your	computer	via	the	USB	port.	If
you	are	using	a	Linux	or	Windows	OS,	you	may	need	to	perform	additional	steps	to	run	your	app	on	a	hardware	device.	Check	the	Run	Apps	on	a	Hardware	Device	documentation.	On	Windows,	you	may	need	to	install	the	appropriate	USB	driver	for	your	device.	See	OEM	USB	Drivers.	Run	your	app	on	a	device	To	let	Android	Studio	communicate	with
your	device,	you	must	turn	on	USB	Debugging	on	your	Android	device.	On	Android	4.2	and	higher,	the	Developer	options	screen	is	hidden	by	default.	To	show	Developer	options	and	enable	USB	Debugging:	On	your	device,	open	Settings	>	About	phone	and	tap	Build	number	seven	times.	Return	to	the	previous	screen	(Settings).	Developer	options
appears	at	the	bottom	of	the	list.	Tap	Developer	options.	Enable	USB	Debugging.	Now	you	can	connect	your	device	and	run	the	app	from	Android	Studio.	Connect	your	device	to	your	development	machine	with	a	USB	cable.	On	the	device,	you	might	need	to	agree	to	allow	USB	debugging	from	your	development	device.	In	Android	Studio,	click	Run	in
the	toolbar	at	the	top	of	the	window.	(You	might	need	to	select	View	>	Toolbar	to	see	this	option.)	The	Select	Deployment	Target	dialog	opens	with	the	list	of	available	emulators	and	connected	devices.	Select	your	device,	and	click	OK.	Android	Studio	installs	the	app	on	your	device	and	runs	it.	Note:	If	your	device	is	running	an	Android	platform	that
isn't	installed	in	Android	Studio,	you	might	see	a	message	asking	if	you	want	to	install	the	needed	platform.	Click	Install	and	Continue,	then	click	Finish	when	the	process	is	complete.	Troubleshooting	If	you're	stuck,	quit	Android	Studio	and	restart	it.	If	Android	Studio	does	not	recognize	your	device,	try	the	following:	Disconnect	your	device	from	your
development	machine	and	reconnect	it.	Restart	Android	Studio.	If	your	computer	still	does	not	find	the	device	or	declares	it	"unauthorized":	Disconnect	the	device.	On	the	device,	open	Settings->Developer	Options.	Tap	Revoke	USB	Debugging	authorizations.	Reconnect	the	device	to	your	computer.	When	prompted,	grant	authorizations.	If	you	are	still
having	trouble,	check	that	you	installed	the	appropriate	USB	driver	for	your	device.	See	the	Using	Hardware	Devices	documentation.	Check	the	troubleshooting	section	in	the	Android	Studio	documentation.	Step	7:	Explore	the	app	template	When	you	created	the	project	and	selected	Basic	Activity,	Android	Studio	set	up	a	number	of	files,	folders,	and
also	user	interface	elements	for	you,	so	you	can	start	out	with	a	working	app	and	major	components	in	place.	This	makes	it	easier	to	build	your	application.	Looking	at	your	app	on	the	emulator	or	your	device,	in	addition	to	the	Next	button,	notice	the	floating	action	button	with	an	email	icon.	If	you	tap	that	button,	you'll	see	it	has	been	set	up	to	briefly
show	a	message	at	the	bottom	of	the	screen.	This	message	space	is	called	a	snackbar,	and	it's	one	of	several	ways	to	notify	users	of	your	app	with	brief	information.	At	the	top	right	of	the	screen,	there's	a	menu	with	3	vertical	dots.	If	you	tap	on	that,	you'll	see	that	Android	Studio	has	also	created	an	options	menu	with	a	Settings	item.	Choosing
Settings	doesn't	do	anything	yet,	but	having	it	set	up	for	you	makes	it	easier	to	add	user-configurable	settings	to	your	app.	Later	in	this	codelab,	you'll	look	at	the	Next	button	and	modify	the	way	it	looks	and	what	it	does.	Generally,	each	screen	in	your	Android	app	is	associated	with	one	or	more	fragments.	The	single	screen	displaying	"Hello	first
fragment"	is	created	by	one	fragment,	called	FirstFragment.	This	was	generated	for	you	when	you	created	your	new	project.	Each	visible	fragment	in	an	Android	app	has	a	layout	that	defines	the	user	interface	for	the	fragment.	Android	Studio	has	a	layout	editor	where	you	can	create	and	define	layouts.	Layouts	are	defined	in	XML.	The	layout	editor
lets	you	define	and	modify	your	layout	either	by	coding	XML	or	by	using	the	interactive	visual	editor.	Every	element	in	a	layout	is	a	view.	In	this	task,	you	will	explore	some	of	the	panels	in	the	layout	editor,	and	you	will	learn	how	to	change	property	of	views.	What	you'll	learn	How	to	use	the	layout	editor.	How	to	set	property	values.	How	to	add	string
resources.	How	to	add	color	resources.	Step	1:	Open	the	layout	editor	Find	and	open	the	layout	folder	(app	>	res	>	layout)	on	the	left	side	in	the	Project	panel.	Double-click	fragment_first.xml.	Troubleshooting:	If	you	don't	see	the	file	fragment_first.xml,	confirm	you	are	running	Android	Studio	3.6	or	later,	which	is	required	for	this	codelab.	The	panels
to	the	right	of	the	Project	view	comprise	the	Layout	Editor.	They	may	be	arranged	differently	in	your	version	of	Android	Studio,	but	the	function	is	the	same.	On	the	left	is	a	Palette	(1)	of	views	you	can	add	to	your	app.	Below	that	is	a	Component	Tree	(2)	showing	the	views	currently	in	this	file,	and	how	they	are	arranged	in	relation	to	each	other.	In
the	center	is	the	Design	editor	(3),	which	shows	a	visual	representation	of	what	the	contents	of	the	file	will	look	like	when	compiled	into	an	Android	app.	You	can	view	the	visual	representation,	the	XML	code,	or	both.	In	the	upper	right	corner	of	the	Design	editor,	above	Attributes	(4),	find	the	three	icons	that	look	like	this:	These	represent	Code	(code
only),	Split	(code	+	design),	and	Design	(design	only)	views.	Try	selecting	the	different	modes.	Depending	on	your	screen	size	and	work	style,	you	may	prefer	switching	between	Code	and	Design,	or	staying	in	Split	view.	If	your	Component	Tree	disappears,	hide	and	show	the	Palette.	Split	view:	At	the	lower	right	of	the	Design	editor	you	see	+	and	-
buttons	for	zooming	in	and	out.	Use	these	buttons	to	adjust	the	size	of	what	you	see,	or	click	the	zoom-to-fit	button	so	that	both	panels	fit	on	your	screen.	The	Design	layout	on	the	left	shows	how	your	app	appears	on	the	device.	The	Blueprint	layout,	shown	on	the	right,	is	a	schematic	view	of	the	layout.	Practice	using	the	layout	menu	in	the	top	left	of
the	design	toolbar	to	display	the	design	view,	the	blueprint	view,	and	both	views	side	by	side.	Depending	on	the	size	of	your	screen	and	your	preference,	you	may	wish	to	only	show	the	Design	view	or	the	Blueprint	view,	instead	of	both.	Use	the	orientation	icon	to	change	the	orientation	of	the	layout.	This	allows	you	to	test	how	your	layout	will	fit
portrait	and	landscape	modes.	Use	the	device	menu	to	view	the	layout	on	different	devices.	(This	is	extremely	useful	for	testing!)	On	the	right	is	the	Attributes	panel.	You'll	learn	about	that	later.	Step	2:	Explore	and	resize	the	Component	Tree	In	fragment_first.xml,	look	at	the	Component	Tree.	If	it's	not	showing,	switch	the	mode	to	Design	instead	of
Split	or	Code.	This	panel	shows	the	view	hierarchy	in	your	layout,	that	is,	how	the	views	are	arranged	in	relation	to	each	other.	2.	If	necessary,	resize	the	Component	Tree	so	you	can	read	at	least	part	of	the	strings.	3.	Click	the	Hide	icon	at	the	top	right	of	the	Component	Tree.	The	Component	Tree	closes.	4.	Bring	back	the	Component	Tree	by	clicking
the	vertical	label	Component	Tree	on	the	left.	Step	3:	Explore	view	hierarchies	In	the	Component	Tree,	notice	that	the	root	of	the	view	hierarchy	is	a	ConstraintLayout	view.	Every	layout	must	have	a	root	view	that	contains	all	the	other	views.	The	root	view	is	always	a	view	group,	which	is	a	view	that	contains	other	views.	A	ConstraintLayout	is	one
example	of	a	view	group.	2.	Notice	that	the	ConstraintLayout	contains	a	TextView,	called	textview_first	and	a	Button,	called	button_first.	If	the	code	isn't	showing,	switch	to	Code	or	Split	view	using	the	icons	in	the	upper	right	corner.	In	the	XML	code,	notice	that	the	root	element	is	.	The	root	element	contains	a	element	and	a	element.	Step	4:	Change
property	values	In	the	code	editor,	examine	the	properties	in	the	TextView	element.	Click	on	the	string	in	the	text	property,	and	you'll	notice	it	refers	to	a	string	resource,	hello_first_fragment.	android:text="@string/hello_first_fragment"	Right-click	on	the	property	and	click	Go	To	>	Declaration	or	Usages	values/strings.xml	opens	with	the	string
highlighted.	Hello	first	fragment	Change	the	value	of	the	string	property	to	Hello	World!.	Switch	back	to	fragment_first.xml.	Select	textview_first	in	the	Component	Tree.	Look	at	the	Attributes	panel	on	the	right,	and	open	the	Declared	Attributes	section	if	needed.	Troubleshooting	this	step:	If	the	Attributes	panel	is	not	visible,	click	the	vertical
Attributes	label	at	the	top	right.	In	the	text	field	of	the	TextView	in	Attributes,	notice	it	still	refers	to	the	string	resource	@string/hello_first_fragment.	Having	the	strings	in	a	resource	file	has	several	advantages.	You	can	change	the	value	of	string	without	having	to	change	any	other	code.	This	simplifies	translating	your	app	to	other	languages,
because	your	translators	don't	have	to	know	anything	about	the	app	code.	Tip:	To	find	a	property	in	the	list	of	all	the	properties,	click	on	the	magnifying	glass	icon	to	the	right	of	Attributes,	and	begin	typing	the	name	of	the	property.	Android	Studio	will	show	just	the	properties	that	contain	that	string.	Run	the	app	to	see	the	change	you	made	in
strings.xml.	Your	app	now	shows	"Hello	World!".	Step	5:	Change	text	display	properties	With	textview_first	still	selected	in	the	Component	Tree,	in	the	layout	editor,	in	the	list	of	attributes,	under	Common	Attributes,	expand	the	textAppearance	field.	(You	may	need	to	scroll	down	to	find	it.)	Change	some	of	the	text	appearance	properties.	For	example,
change	the	font	family,	increase	the	text	size,	and	select	bold	style.	(You	might	need	to	scroll	the	panel	to	see	all	the	fields.)	Change	the	text	color.	Click	in	the	textColor	field,	and	enter	g.	A	menu	pops	up	with	possible	completion	values	containing	the	letter	g.	This	list	includes	predefined	colors.	Select	@android:color/darker_gray	and	press	Enter.
Below	is	an	example	of	the	textAppearance	attributes	after	making	some	changes.	Look	at	the	XML	for	the	TextView.	You	see	that	the	new	properties	have	been	added.	BottomOf	textView.	Take	a	look	at	the	XML	code	for	the	button.	It	now	includes	the	attribute	that	constrains	the	top	of	the	button	to	the	bottom	of	the	TextView.
app:layout_constraintTop_toBottomOf="@+id/textview_first"	You	may	see	a	warning,	"Not	Horizontally	Constrained".	To	fix	this,	add	a	constraint	from	the	left	side	of	the	button	to	the	left	side	of	the	screen.	Also	add	a	constraint	to	constrain	the	bottom	of	the	button	to	the	bottom	of	the	screen.	Before	adding	another	button,	relabel	this	button	so
things	are	a	little	clearer	about	which	button	is	which.	Click	on	the	button	you	just	added	in	the	design	layout.	Look	at	the	Attributes	panel	on	the	right,	and	notice	the	id	field.	Change	the	id	from	button	to	toast_button.	Step	4:	Adjust	the	Next	button	You	will	adjust	the	button	labeled	Next,	which	Android	Studio	created	for	you	when	you	created	the
project.	The	constraint	between	it	and	the	TextView	looks	a	little	different,	a	wavy	line	instead	of	a	jagged	one,	with	no	arrow.	This	indicates	a	chain,	where	the	constraints	link	two	or	more	objects	to	each	other,	instead	of	just	one	to	another.	For	now,	you'll	delete	the	chained	constraints	and	replace	them	with	regular	constraints.	To	delete	a
constraint:	In	the	design	view	or	blueprint	view,	hold	the	Ctrl	key	(Command	on	a	Mac)	and	move	the	cursor	over	the	circle	for	the	constraint	until	the	circle	highlights,	then	click	the	circle.	Or	click	on	one	of	the	constrained	views,	then	right-click	on	the	constraint	and	select	Delete	from	the	menu.	Or	in	the	Attributes	panel,	move	the	cursor	over	the
circle	for	the	constraint	until	it	shows	an	x,	then	click	it.	If	you	delete	a	constraint	and	want	it	back,	either	undo	the	action,	or	create	a	new	constraint.	Step	5:	Delete	the	chain	constraints	Click	on	the	Next	button,	and	then	delete	the	constraint	from	the	top	of	the	button	to	the	TextView.	Click	on	the	TextView,	and	then	delete	the	constraint	from	the
bottom	of	the	text	to	the	Next	button.	Step	6:	Add	new	constraints	Constrain	the	right	side	of	the	Next	button	to	the	right	of	the	screen	if	it	isn't	already.	Delete	the	constraint	on	the	left	side	of	the	Next	button.	Now	constrain	the	top	and	bottom	of	the	Next	button	so	that	the	top	of	the	button	is	constrained	to	the	bottom	of	the	TextView	and	the
bottom	is	constrained	to	the	bottom	of	the	screen.	The	right	side	of	the	button	is	constrained	to	the	right	side	of	the	screen.	Also	constrain	the	TextView	to	the	bottom	of	the	screen.	It	may	seem	like	the	views	are	jumping	around	a	lot,	but	that's	normal	as	you	add	and	remove	constraints.	Your	layout	should	now	look	something	like	this.	In	the
fragment_first.xml	layout	file,	find	the	text	property	for	the	toast_button	button.	strings.xml	file.	Notice	that	a	new	string	resource	has	been	added,	named	toast_button_text.	...	Toast	Run	the	app	to	make	sure	it	displays	as	you	expect	it	to.	You	now	know	how	to	create	new	string	resources	by	extracting	them	from	existing	field	values.	(You	can	also
add	new	resources	to	the	strings.xml	file	manually.)	And	you	know	how	to	change	the	id	of	a	view.	Note:	The	id	for	a	view	helps	you	identify	that	view	distinctly	from	other	views.	You'll	use	this	later	to	find	particular	views	using	the	findViewById()	method	in	your	Java	code.	The	Next	button	already	has	its	text	in	a	string	resource,	but	you'll	make	some
changes	to	the	button	to	match	its	new	role,	which	will	be	to	generate	and	display	a	random	number.	As	you	did	for	the	Toast	button,	change	the	id	of	the	Next	button	from	button_first	to	random_button	in	the	Attributes	panel.	If	you	get	a	dialog	box	asking	to	update	all	usages	of	the	button,	click	Yes.	This	will	fix	any	other	references	to	the	button	in
the	project	code.	In	strings.xml,	right-click	on	the	next	string	resource.	Select	Refactor	>	Rename...	and	change	the	name	to	random_button_text.	Click	Refactor	to	rename	your	string	and	close	the	dialog.	Change	the	value	of	the	string	from	Next	to	Random.	If	you	want,	move	random_button_text	to	below	toast_button_text.	Step	9:	Add	a	third	button
Your	final	layout	will	have	three	buttons,	vertically	constrained	the	same,	and	evenly	spaced	from	each	other.	In	fragment_first.xml,	add	another	button	to	the	layout,	and	drop	it	somewhere	between	the	Toast	button	and	the	Random	button,	below	the	TextView.	Add	vertical	constraints	the	same	as	the	other	two	buttons.	Constrain	the	top	of	the	third
button	to	the	bottom	of	TextView;	constrain	the	bottom	of	the	third	button	to	the	bottom	of	the	screen.	Add	horizontal	constraints	from	the	third	button	to	the	other	buttons.	Constrain	the	left	side	of	the	third	button	to	the	right	side	of	the	Toast	button;	constrain	the	right	side	of	the	third	button	to	the	left	side	of	the	Random	button.	Your	layout	should
look	something	like	this:	Examine	the	XML	code	for	fragment_first.xml.	Do	any	of	the	buttons	have	the	attribute	app:layout_constraintVertical_bias?	It's	OK	if	you	do	not	see	that	constraint.	The	"bias"	constraints	allows	you	to	tweak	the	position	of	a	view	to	be	more	on	one	side	than	the	other	when	both	sides	are	constrained	in	opposite	directions.	For
example,	if	both	the	top	and	bottom	sides	of	a	view	are	constrained	to	the	top	and	bottom	of	the	screen,	you	can	use	a	vertical	bias	to	place	the	view	more	towards	the	top	than	the	bottom.	Here	is	the	XML	code	for	the	finished	layout.	Your	layout	might	have	different	margins	and	perhaps	some	different	vertical	or	horizontal	bias	constraints.The	exact
values	of	the	attributes	for	the	appearance	of	the	TextView	might	be	different	for	your	app.
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